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Fallstudie terrestrisches Laser-Scanning: 
 

Am Beispiel eines Laser-Radar-Scanners der Firma Riegl werden  die wichtigsten 
Schritte zur Verarbeitung von Scan-Daten in PolyWorks erläutert. 

 

 
In der Version 8.0 von PolyWorks sind viele 
 neue Funktionen zur Landvermessung und 
Gebäudevermessung hinzugekommen.  

 
Scan-Daten lassen sich mit dem Best-Fit- 
Verfahren aufeinander ausrichten und als 
ein Gesamtdatensatz bearbeiten. 
 
Nahezu alle optischen Scanner  
werden von PolyWorks direkt unterstützt.  
 
 
 
 
 
 

InnovMetric at a  glance 

Founded in 1994, InnovMetric pioneered the market for point cloud inspection and 

polygonal manufacturing software solutions. InnovMetric is a privately-owned 

company which has sustained an 86% average yearly growth. InnovMetric’s culture 

is focused on its users constant feedback and on the ability of InnovMetric’s team 

to transform such feedback into groundbreaking innovations for increased user 

productivity. Today, PolyWorks licenses are at work daily in more than 30 countries, 

benefiting users with the most complete, accurate, and robust 3D point cloud 

processing software solution on the market.  
 

© 2003 InnovMetric Software Inc. All rights reserved. PolyWorks® is a registered trademark of 
InnovMetric Inc. InnovMetric, PolyWorks®/Modeler, PolyWorks®/Inspector, IMAlign, IMMerge, 
IMEdit, IMCompress, IMInspect, IMTexture and IMView are trademarks of InnovMetric Software Inc. 
All  other trademarks are property of their respective owners.  
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Long Range Data Processing Overview 
 
 

 
 
 
 
 
 
 
 
 
 
 

 
 

 
 

  

 

 

Data Acquisition
 

As explained in the previous sections, use a 
digitizer to acquire data point clouds from the 
field and then export them into a PolyWorks-
supported file format. 
To speed up the next alignment step, get the 
relative position X, Y, Z of the scanner in a 
global or local coordinate system. 
 
 
 
Use IMAlign to bring the scans into one 
coordinate system. No targets are required 
either – IMAlign’s technology uses the 
object’s shapes in the scene to accurately and 
precisely align the scans. If the scanner 
position is known, use it as a fixed rotation 
centers. 
 
 
 
Use IMInspect to geo-reference the aligned 
Geo-referencing 
Alignment of multiple scans 
 

 
 
 
 
 
 
 

 

scans to a large-number coordinate system, 
such as the ones produced by GPS devices. 
 
 
 
 
 
 
 
Use IMInspect tools to extract lines and 
geometric features, create profiles and 
contours, and take measurements. 
 
 
 
 
From IMInspect, export the desired 
information to the IGES or the DXF file 
formats. Use the feature code and the DXF 
layer name. 

CAD Exportation 

Feature Extraction 
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PolyWorks Basics 
 
1 – Starting PolyWorks modules 
 
1. Start the PolyWorks Module Access Center 

(MAC).
2. Start your module by clicking its tab, 

giving parameters if necessary, and 
clicking Start.

 
 

 

(MAC) 
Shortcuts for the main 
PolyWorks modules 

 
 
 
 
 
 
 
 
2 – Interface Basics 
 
The IMAlign, IMEdit, and IMView interfaces work much the same way - saving you time. Here are 
some common features important for new users. Each interface is detailed in the appropriate 
learning section. 

 

 
 
 
 
 
 

1  Config > Interactive Mode Wizard
Set the Wizard for a complete 
description of most operations.

2  Undo > Undo (Description of action)
Undo the described action. A Redo 
function is also offered. 

3  Help > Help Topics
An informative database.

4  Help > Module Reference Guide
A complete PDF reference guide 
with dynamic links (Acrobat 3.0 or 
later).
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3 – Visualization in IMAlign, IMEdit, and IMView 
 
These modules offer various display modes to let you best visualize your objects. 

 

Bounding Box

Only the bounding box 
frame of the 3D surface is 
visible.

Wireframe

Displays the 3D surface as 
a mesh-like wireframe 
display.

Smooth

Displays the 3D surface as 
a smooth-shaded surface.

Flat

Displays the 3D surface as 
a flat-shaded surface made 
of triangles.

Flat + Wireframe

Displays the 3D surface as 
a combination of flat 
shading and wireframe. 
Offered in IMEdit/IMView.

Point

Displays the 3D surface as 
a 3D point cloud.

 
4 – Positioning scans/polygonal models 
 
Use the mouse to position scans in IMAlign, or polygonal models in IMEdit and IMView, in the 
3D scene along the x, y, or z viewing axes. Each of the modes uses its own cursor for user 
feedback.  

Mouse 
movement

Rotational axis

ROTATE X&Y

Left-click and drag.

Rotates around the x 
and y viewing axes.
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ZOOM

Right-click and drag.

Translates along the z 
axis. Forward move
ment increases object 
size, while backward 
movement decreases 
object size.

SHIFT +  

ROTATE Z

Press and hold the 
SHIFT key, and then 
right-click and drag.

Rotates about the z 
axis.

Mouse movement

TRANSLATE

Middle-click and 
drag.

Translates along the 
x and y axes.

Mouse 
movementRotational axis

ROTATE X OR Y

Press and hold the 
SHIFT key, and then 
left-click and drag.

Rotates around only 
the horizontal or the 
vertical viewing axis, 
depending on the ini
tial 10-pixel direc
tion of the mouse 
movement.

SHIFT +  
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SHIFT

Left Middle Right

ZoomTranslation

Zoom Screen
Plane

RotationWindow

Rotation

MOUSE MAP

For positioning 
objects in the 3D 
scene.

Note that if your 
mouse has a wheel as 
the middle mouse but
ton, rolling it will per
form the zoom 
function.

Hold down the CTRL key during consecutive rotations/
translations to avoid screen redrawing after each action.

ZOOM WINDOW

Press and hold the 
SHIFT key, and then 
middle-click and drag 
to open a window.

Zooms selected fea
tures.

SHIFT +  

NONE 

Horizontal 
or Vertical
Rotation

SHIFT +  
ROTATE Z
(90° increments)

Press and hold the 
SHIFT key, and then 
right-click once 
quickly for a 90° 
rotation.

Rotates counter 
clockwise about the 
z axis by 90°.
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Step-by-step 
 
A. Alignment 
 
1. Overview 

 
IMAlign is an invaluable tool for bringing all of your scans in the same coordinate system, based on 
the object’s shapes in the scene. 
 
For IMAlign to work correctly, scans must meet two criteria. First, each scan must share some 
redundant information with adjacent scans (overlap). And secondly, each scan overlap should 
contain shape variations in the scene that constrain all of the degrees of freedom, since IMAlign 
does a shape-based alignment. For example, two scans of a flat surface, even with overlap, may not 
align properly due to the lack of shape variations. 
 
Depending on the equipment and the information collected in the field, we can align following 
three typical scenarios: 
 
 
1ST

 SCENARIO: Alignment based on the object’s shapes in the scene (standard alignment). In this case, 
we only need sufficient overlap and constraining shape  variations in the overlapping regions to 
align the scans. 
 
 

2ND
 SCENARIO: The relative scanner position coordinates are 

known (constrained alignment). All but the rotational 
degrees of freedom are constrained for all the scans. Note 
that the alignment software doesn’t support large 
numbers, such as those produced by GPS devices. 
 
 
3RD

 SCENARIO: The relative scanner position coordinates are 
known and the orientation of the first scan is known 
(constrained alignment). This scenario is similar to the 
second one except that the first scan is exact in position 
and orientation. The rotational degrees of freedom are 
free of constraint only for the subsequent scans. 
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2. Alignment Processes 

 
In the following pages, we present diagrams of the alignment process of the three typical 
scenarios. You will notice few differences but they are very important for the extraction of all the 
potential of your data. The output at the end of each scenario process is the same - it’s a project 
file called an IMAlign group. 
 
1ST

 SCENARIO: Alignment based on the object’s natural shapes in the scans (standard alignment). 
 
 
 
 
 
 
 
 
 
 
The privileged alignment technique here for the initial alignment is the selection of corresponding 
pairs of points. PolyWorks IMAlign has an interface to display side by side the scans to enable an 

easy picking of corresponding points ( ). The initial alignment will then be improved by an 
iterative best-fit alignment. The best-fit alignment is the step that is labeled Optimize in the 
diagram. 
 

 
 
 
2ND

 SCENARIO: The relative scanner position coordinates are known (constrained alignment). 
 
 
 
 
 
 

Import 
next scan 

• Optimize globally
• Save project 
 

• Align (N Point Pairs)
• Optimize  
• Lock scan 

•

•  

Import 
next scan 

•
•  
•

Position 
scan 
 

Import 
1st scan 
 

• Optimize globally
• Save project 
 

 

 

 Position scan 
 Align manually
 Optimize 
(SEQUENTIAL) 
 Import 1st 
scan 

 Lock scan
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This scenario presents an additional step – positioning the scans using their relative scanner 
coordinates (also referred to as rotation centers). Then the alignment technique uses fixed rotation 
centers that only allows you to rotate the scans to provide a rough alignment. The recommended 
alignment technique is interactive 3D rotation using sliders. This step lets you quickly position the 
scans one relative to the other. 
 
The use of the best-fit (Optimize) alignment method is also different since none of the scans have 
an exact orientation. And therefore each scan must be able to rotate to achieve an exact 
orientation. As a result, no one of them can be permanently locked and have its orientation not 
change. In this case, we propose a Sequential Subgroup Lock toggle that locks sequentially one 
scan at a time and runs 1 best-fit iteration at a time. 
 

 
 
 
 
3RD

 SCENARIO: The relative scanner position coordinates are known and the orientation of a scan is 
known (constrained alignment). 

Import 
a scan 
 

Import 
next scan 

• P  
• A

m
• O

• Position and 
orient scan  

• Lock scan 

• Optimize globally
• Save project 
 

 

 

osition scan 
lign 
anually 
ptimize 
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The particularity of this scenario is that a scan must have a correct orientation. The correct 
orientation is achieved using a minimum of three targets in the scene of the scan, and processing 
in the 3D RiScan or IMInspect software. 
 

1 Configure PolyWorks IMAlign 
 

• Open the PolyWorks Module Access Center and start the IMAlign software 
• Choose your digitizer from the proposed list. IMAlign will automatically assign 

values to certain parameters. 
�  Config > Digitizer 
 

 
 

 
These settings must be adjusted in accordance with the digitizer units 
 

 
 
 
 

 NOTE 

• Save the configuration to set it as the default 
� Config > Save 

• Create a project directory for future imported files 
� File > Save Group As 

 
2 Import a scan into PolyWorks 

• � File > Import Group > Create Subgroup 
• � File > Import Group > 3DD Files …  
• Set the importation parameters 
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A Maximum angle of 87 degrees is recommended for flat surfaces such as 
road scans. 
 

 
 

Tech 
Tip 

• Subdivide by range to assign to each subdivision a progressive step. It’s the key to 
using less RAM and importing many scans. 
The recommended near step is approximately 3*Standard Deviation (sigma). 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Maximum distance

40

20

0
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To remove mobile objects like automobiles, we need two scans of the same scene. Why 
remove the data points captured on mobile objects? Since IMAlign does a shape-based 
alignment, IMAlign considers those points as objects used to align the scans’ position and 
orientation. 
 

• Delete data points of mobile objects (ex: cars, pedestrians,…) in the scene to improve 
the quality of the alignment between scans. 
In the Tree View, select the first scan to be cleaned, and then 
� Edit > Delete Non-Overlapping Points… 

• Delete the second scan that was used for deleting the data points of the mobile 
objects 
In the Tree View, select the second scan, and then 
� Edi t> Object Tree > Delete 

 
 

3   Position the Scan (2nd scenario) 
 
 

Position your scan using the relative scanner coordinates. Furthermore, it can also 
be oriented if, during your scan campaign, you always start your digitizer from the 
same monument located as far as possible from the scanner and visible from every 
scanner location. It’s as valid as if you start your digitizer using the same direction 
on a compass (ex: All scans start from the North direction). 

 
 

 
 
 

Tech 
Tip 

Measured antenna height 

Distance between the origin and 
the top of the scanner is 
available in the scanner manual. Origin 

• Translate negatively your scan along the Z axis by the distance between the origin 
and the top of the scanner plus the measured antenna height. 

 
In the Tree View, select the images related to the scan, and then 
� Align > Manual Alignment > 3D Translation 
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• Translate the scan to its known ground coordinate position. The scanner origin is at 

0,0,0 by default. From the field work, the relative scanner position can be obtained 
from many measurement devices, such as GPS, theodolites, etc. When you translate 
the scan to the scanner position ground coordinates, you position this scan relative 
to the others. 

 
 

IMAlign does not support large numbers. The ground coordinates, such as 
GPS values, must be truncated. 
The coordinates must be in the units of the scanner coordinates system. 
 

 
In the Tree View, select the images related to the scan, and then 
� Align > Manual Alignment > 3D Translation 

 

 
 

 NOTE 

Enter the known (truncated if 
necessary) scanner coordinates X, Y 
and Z (Easting, Northing and 
Elevation) 
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• Constrain the alignment about the customized rotation center within a specified 
tolerance (potential instrument error) to fix the position of the scanner (now X, Y, 
and “Z-1st translation” ground coordinates) in the best-fit alignment process. 

 
You must re-enter the Z value in the Custom field without the 1st translation 
subtraction. 
 
In the Tree View, select the images related to the scan, and then 
 
� Right-click and select Properties > Constraints 

 

 
 

• Do not lock the imported scan 
 

 
In the 2nd scenario, you must not lock any scans (or subgroups), the 
Sequential Subgroup Lock will take care of that operation 

 
 

 NOTE 
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4  Position and Orient Scan (3rd scenario) 
 

 The alignment of a scan in the 3rd scenario is based on a known scanner orientation. The 
orientation can be achieved through the application of a transformation matrix, generated 
by IMInspect. The transformation matrix is the result of using IMInspect’s N Pairs of Center 
Points alignment method, where the center points are provided by a minimum of three 
targets (or physical details) visible in the scan and their known ground coordinates.  

 
• In IMAlign, position and orient the first scan using the transformation matrix saved 

in IMInspect. 
In the Tree View, select the images related to the scan, and then 
� Edit > Image Tree > Apply Matrix 

• Lock the aligned scan 
In the Tree View, select the images related to the scan, and then 
� Edit > Image Tree > Lock  

 
1 Repeat until the last scan 
• Import the next scan. Refer to step 2. 
• Position the scan. Refer to the previous step 3 (2nd scenario). 
• Align graphically the imported scan. 
 
 

For a smooth display while you align graphically in the Global mode, set the Static 
Mode display to Point and 1/64. 

 
 

Select in the Tree View the last imported scan, and then 
� Align > Manual Alignment > 3D Rotation > Use Sliders 

 

 
 

Tech 
Tip 

• In the 2nd scenario, optimize the alignment using the Sequential Subgroup lock that 
lock one scan at a time and run one best-fit alignment iteration.  
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• In the 3rd scenario, optimize the alignment using the best-fit method. Make sure the 
Allow constraints is checked 

 
 

2 Optimize globally the alignment using the best-fit alignment method.  
 
 

Don’t forget to use the Sequential Subgroup lock to do so for the 2nd scenario 
alignment.  
 
 
 
 

Select in the Tree View all the scans except the first one, and then 
Edit > Image Tree > Release 
Align > Image Alignment & Comparison 
 
 
 
For the 2nd and the 3rd alignment scenarios, Allow constraints must be checked. 
 
 

 
 

 NOTE 

• Save the alignment project to an IMAlign Group directory 
� File > Save Group 

• Exit IMAlign 
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Step-by-step 
 

B. Information extraction 
 
1. Overview of objective and relevant tools 

 
In PolyWorks IMInspect, we have developed unique tools to facilitate the extraction of features 
directly on the data point cloud, and for exporting these features as CAD drawings. 
 
There are many different tools dedicated to long range applications. Just to give you a sample list: 

• Unique geo-referencing approach for accurate measurements 
• Automatic edge extraction tool 
• Extraction of polylines based on color or intensity criteria 
• Profile & contour creation from the point cloud 
• Polyline feature code and assign a DXF layer name 
• Interactive measurements (bearing, azimuth, horizontal distance, …) 

 
2. Measurement process 
 

1 Configure PolyWorks IMInspect 
• Open the PolyWorks Module Access Center and start the IMInspect software 
• Set the units. In turn, IMInspect will convert a list of default parameters to those 

units 
 
� Config > Units 
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• Scale your project to establish the correspondence with your ground coordinate 

system units 
 

�  Edit > Scale 
 

 
 
• Save the configuration to set it as the default 

 
� Config>Save 

 
2 Import the IMAlign Group project as Data 

 
� File > Import Data > IMAlign Group 

 
3 To prepare the geo-reference, you need to translate your scan to large numbers, such as 

the coordinate values of a GPS point.  
 
 
� Align > Set huge translation 

 

 
 

If you have identifiable targets in your scans, the matching of scene targets with their 
known ground position is done using: 
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� Align > N Pairs of Center Points 
 

 
 

4 Extract feature lines 
 

• To extract clean features lines, some objects may have to be removed from a scene. 
Here is a quick method for eliminating vertical objects in a scene, such as poles, cars, 
trees… 
 
Ignore points without normal 

 
� Select > Select data with normal vectors 

 
 

•  
•  
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• To import a feature code file 
 

� Report> Feature Code > Manage List 
 

 
 
• Here is a sample list of the available tools that can be used to manually or 

automatically extract feature lines: 
� Primitive >Polyline > Properties (feature code, DXF layer name) 
� Primitive >Polyline > Anchor 
� Primitive >Polyline > Extract Edge 
� Primitive >Polyline > Extract from Colors 
�Primitive >Polyline > Extract Step Edge 
� Primitive >Polyline > Offset 
� Primitive >Polyline > Magnetize Endpoints 
� Primitive >Polyline > Project onto Plane 

 
• Assign a feature code to a selection of primitives 

� Report >Feature Code > Assign Code to Primitives… 
 

5 Extract geometric features (ex: trees, signs, pole locations…) 
 
6 Extract profiles and contours 

• Create profiles along an existing polyline 
� Compare > Cross-Sections > Create along Curve… 

• Generate contours 
� Edit >Triangulate… (breaklines) 
� Compare > Cross-Sections > Create Parallel… 

• Edit cross-sections 
� Primitive > Polyline > From Cross-Sections 
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7 Measure 

• � Measure > Angle, Distance, Radius… 
 

 
 

• � Measure > Surface-to-Plane Volume… 
 

8 Export 
• � File > Export Object > Primitives & Cross-Sections to DXF… 
• Save the IMInspect project 

� File > Save Project As… 
• Exit IMInspect 

� File > Exit 
 

 

  


	☞ Config > Save
	☞ File > Save Group As
	In the Tree View, select the first scan to be cleaned, and t
	☞ Edit > Delete Non-Overlapping Points…


	In the Tree View, select the second scan, and then
	In the Tree View, select the images related to the scan, and
	In the Tree View, select the images related to the scan, and
	☞ Align > Manual Alignment > 3D Translation
	In the Tree View, select the images related to the scan, and
	☞ Right-click and select Properties > Constraints
	In the Tree View, select the images related to the scan, and
	In the Tree View, select the images related to the scan, and


	Select in the Tree View the last imported scan, and then
	☞ Align > Manual Alignment > 3D Rotation > Use Sliders
	☞ File > Save Group
	☞ Config>Save
	☞ File > Import Data > IMAlign Group
	☞ Align > Set huge translation
	To extract clean features lines, some objects may have to be
	Ignore points without normal
	☞ Select > Select data with normal vectors





	☞ File > Save Project As…
	☞ File > Exit




